pyproject.toml

changeset 2
5b635dc8895f
child 4
312607fef6f7
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Fri Apr 18 18:36:48 2025 +0200
@@ -0,0 +1,17 @@
+
+[tool.isort]
+profile = "black"
+sort_order = "natural"
+supported_extensions = ["pyi", "pxd", "pyx", "py"]
+combine_as_imports = true
+extend_skip_glob = ["*/Ui_*.py"]
+known_first_party = ["ExtensionIrc", "eric7"]
+
+[tool.black]
+target-version = ["py313", "py312", "py311", "py310", "py39"]
+line-length = 88
+extend-exclude = '''
+/(
+    Ui_.*\.py
+)
+'''

eric ide

mercurial