pyproject.toml

changeset 4
312607fef6f7
parent 2
5b635dc8895f
--- a/pyproject.toml	Sun Apr 20 11:08:39 2025 +0200
+++ b/pyproject.toml	Sun Apr 20 11:42:47 2025 +0200
@@ -1,12 +1,3 @@
-
-[tool.isort]
-profile = "black"
-sort_order = "natural"
-supported_extensions = ["pyi", "pxd", "pyx", "py"]
-combine_as_imports = true
-extend_skip_glob = ["*/Ui_*.py"]
-known_first_party = ["ExtensionIrc", "eric7"]
-
 [tool.black]
 target-version = ["py313", "py312", "py311", "py310", "py39"]
 line-length = 88
@@ -15,3 +6,12 @@
     Ui_.*\.py
 )
 '''
+
+[tool.isort]
+profile = "black"
+sort_order = "natural"
+supported_extensions = ["pyi", "pxd", "pyx", "py"]
+lines_between_types = 1
+combine_as_imports = true
+extend_skip_glob = ["*/Ui_*.py"]
+known_first_party = ["ExtensionIrc", "eric7"]

eric ide

mercurial