setup.py

branch
setup.py
changeset 6958
949c3c76cc8a
parent 6951
ef3e87580dc9
child 7192
a22eee00b052
child 7216
4dd9231b349e
--- a/setup.py	Fri Apr 19 17:59:43 2019 +0200
+++ b/setup.py	Sat Apr 20 19:01:54 2019 +0200
@@ -66,7 +66,7 @@
 
 def getDataFiles():
     """
-    Return data_files in a platform dependent manner.
+    Function to return data_files in a platform dependent manner.
     
     @return list containing the platform specific data files
     @rtype list of tuples of (str, list of str)
@@ -94,6 +94,28 @@
         dataFiles = []
     return dataFiles
 
+
+def getLongDescription():
+    """
+    Function to get the long description via the README file.
+    
+    @return long description
+    @rtype str
+    """
+    with open(os.path.join(os.path.dirname(__file__), "docs", "README.rst"),
+              "r") as f:
+        longDescription = f.read()
+    
+    if not longDescription:
+        longDescription = (
+            "eric6 is an integrated development environment for the Python"
+            " programming language. It uses the PyQt5 bindings and the"
+            " QScintilla2 editor widget. See"
+            " https://eric-ide.python-projects.org for more details."
+        )
+    
+    return longDescription
+
 ######################################################################
 ## functions to prepare the sources for building
 ######################################################################
@@ -238,14 +260,12 @@
     print("Preparation finished")           # __IGNORE_WARNING_M801__
 
 setup(
-    name="eric6",
+    name="eric-ide",
     version=Version,
-    description="eric6 is an integrated development environment for the"
+    description="eric-ide is an integrated development environment for the"
                 " Python language.",
-    long_description="eric6 is an integrated development environment for the"
-                     " Python language. It uses the PyQt5 bindings and the"
-                     " QScintilla2 editor widget. See"
-                     " https://eric-ide.python-projects.org for more details.",
+    long_description=getLongDescription(),
+    long_description_content_type="text/x-rst",
     author="Detlev Offenbach",
     author_email="detlev@die-offenbachs.de",
     url="https://eric-ide.python-projects.org",

eric ide

mercurial