setup.py

branch
without_py2_and_pyqt4
changeset 7192
a22eee00b052
parent 6958
949c3c76cc8a
child 7220
5cf645f6daab
--- a/setup.py	Sat Aug 31 12:29:57 2019 +0200
+++ b/setup.py	Sat Aug 31 12:58:11 2019 +0200
@@ -137,8 +137,7 @@
         pass
     try:
         hgOut = subprocess.check_output(["hg", "identify", "-i"])
-        if sys.version_info[0] == 3:
-            hgOut = hgOut.decode()
+        hgOut = hgOut.decode()
     except (OSError, subprocess.CalledProcessError):
         hgOut = ""
     if hgOut:

eric ide

mercurial