setup.py

changeset 7220
5cf645f6daab
parent 7216
4dd9231b349e
parent 7192
a22eee00b052
child 7229
53054eb5b15a
--- a/setup.py	Sat Sep 07 14:45:27 2019 +0200
+++ b/setup.py	Sat Sep 07 16:10:29 2019 +0200
@@ -137,8 +137,7 @@
         pass
     try:
         hgOut = subprocess.check_output(["hg", "identify", "-i"])
-        if sys.version_info[0] == 3:
-            hgOut = hgOut.decode()
+        hgOut = hgOut.decode()
     except (OSError, subprocess.CalledProcessError):
         hgOut = ""
     if hgOut:

eric ide

mercurial