pyproject.toml

changeset 3
e73fb9827b74
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Mon Jun 24 17:13:32 2024 +0200
@@ -0,0 +1,19 @@
+[tool.black]
+target-version = ["py38", "py39", "py310", "py311", "py312", "py313"]
+line-length = 88
+extend-exclude = '''
+/(
+    Ui_.*\.py
+)
+'''
+
+[tool.isort]
+profile = "black"
+sort_order = "natural"
+supported_extensions = ["py", "pyi", "pyx", "pxd", "pyw"]
+lines_between_types = 1
+extend_skip_glob = [
+    "*/Ui_*.py",
+]
+combine_as_imports = true
+known_first_party = ["PipxInterface", "eric7"]

eric ide

mercurial