pyproject.toml

branch
eric7-maintenance
changeset 10349
df7edc29cbfb
parent 10272
7ae72d1df070
parent 10341
3fdffd9cc21d
child 10534
783d835d7fe4
--- a/pyproject.toml	Tue Oct 31 09:23:05 2023 +0100
+++ b/pyproject.toml	Wed Nov 29 14:23:36 2023 +0100
@@ -1,5 +1,5 @@
 [build-system]
-requires = ["setuptools>=61.0.0", "wheel"]
+requires = ["setuptools>=64.0.0", "wheel"]
 build-backend = "setuptools.build_meta"
 
 [project]
@@ -32,6 +32,7 @@
     "Operating System :: Microsoft :: Windows :: Windows 10",
     "Operating System :: Microsoft :: Windows :: Windows 11",
     "Operating System :: POSIX :: BSD",
+    "Operating System :: POSIX :: BSD :: FreeBSD",
     "Operating System :: POSIX :: Linux",
     "Programming Language :: Python",
     "Programming Language :: Python :: 3",
@@ -65,6 +66,7 @@
     "PyQt6-QScintilla>=2.13.0",
     "docutils",
     "Markdown",
+    "esprima",
     "pyyaml",
     "tomlkit",
     "chardet",
@@ -82,7 +84,6 @@
     "coverage>=6.5.0",
     "semver",
     "pipdeptree",
-    "importlib-metadata; python_version<'3.8'",
     "pywin32>=1.0;platform_system=='Windows'",
 ]
 dynamic = ["version"]
@@ -132,9 +133,10 @@
 
 [tool.setuptools]
 platforms = [
+    "FreeBSD",
     "Linux",
+    "macOS",
     "Windows",
-    "macOS", 
 ]
 include-package-data = false
 
@@ -181,6 +183,10 @@
     "eric7_ru.qm",
 ]
 
+#
+# black and isort specific parts below
+#
+
 [tool.black]
 target-version = ["py38", "py39", "py310", "py311", "py312"]
 line-length = 88

eric ide

mercurial