setup.py

changeset 8243
cc717c2ae956
parent 8240
93b8a353c4bf
child 8258
82b608e352ec
--- a/setup.py	Thu Apr 15 16:52:05 2021 +0200
+++ b/setup.py	Thu Apr 15 18:11:24 2021 +0200
@@ -395,8 +395,6 @@
 # cleanup
 for fileName in [infoFileName, appdataFileName]:
     if os.path.exists(fileName + ".orig"):
-        try:
+        with contextlib.suppress(OSError):
             os.remove(fileName)
             os.rename(fileName + ".orig", fileName)
-        except OSError:
-            pass

eric ide

mercurial