pyproject.toml

branch
eric7
changeset 9209
b99e7fd55fd3
child 9214
bd28e56047d7
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Thu Jul 07 11:23:56 2022 +0200
@@ -0,0 +1,162 @@
+[build-system]
+requires = ["setuptools>=61.0.0", "wheel"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "eric-ide"
+description = "eric7 is an integrated development environment for the Python language."
+readme = "docs/README.rst"
+authors = [{name = "Detlev Offenbach", email = "detlev@die-offenbachs.de"}]
+classifiers = [
+    "License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
+    "Development Status :: 5 - Production/Stable",
+    "Environment :: MacOS X",
+    "Environment :: Win32 (MS Windows)",
+    "Environment :: X11 Applications",
+    "Environment :: X11 Applications :: Qt",
+    "Intended Audience :: Developers",
+    "Intended Audience :: End Users/Desktop",
+    "Natural Language :: English",
+    "Natural Language :: German",
+    "Natural Language :: Russian",
+    "Natural Language :: Spanish",
+    "Operating System :: MacOS :: MacOS X",
+    "Operating System :: Microsoft :: Windows :: Windows 10",
+    "Operating System :: POSIX :: Linux",
+    "Programming Language :: Python",
+    "Programming Language :: Python :: 3",
+    "Programming Language :: Python :: 3.7",
+    "Programming Language :: Python :: 3.8",
+    "Programming Language :: Python :: 3.9",
+    "Programming Language :: Python :: 3.10",
+    "Programming Language :: Python :: 3.11",
+    "Programming Language :: Python :: Implementation :: CPython",
+    "Topic :: Internet :: WWW/HTTP :: Browsers",
+    "Topic :: Software Development",
+    "Topic :: Software Development :: Debuggers",
+    "Topic :: Software Development :: Testing :: Unit",
+    "Topic :: Software Development :: Version Control :: Git",
+    "Topic :: Software Development :: Version Control :: Mercurial",
+    "Topic :: Text Editors :: Integrated Development Environments (IDE)", 
+]
+keywords = [
+    "Development",
+    "PyQt6",
+    "IDE",
+    "Python3", 
+]
+requires-python = ">=3.7, <3.12"
+dependencies = [
+  "pip>=21.1",
+  "wheel",
+  "PyQt6>=6.2.0",
+  "PyQt6-Charts>=6.2.0",
+  "PyQt6-WebEngine>=6.2.0",
+  "PyQt6-QScintilla>=2.13.0",
+  "docutils",
+  "Markdown",
+  "pyyaml",
+  "tomlkit",
+  "chardet",
+  "asttokens",
+  "EditorConfig",
+  "Send2Trash",
+  "Pygments",
+  "parso",
+  "jedi",
+  "packaging",
+  "pipdeptree",
+  "cyclonedx-python-lib",
+  "cyclonedx-bom",
+  "trove-classifiers",
+  "pywin32>=1.0;platform_system=='Windows'",
+]
+dynamic = ["version"]
+
+[project.urls]
+Homepage = "https://eric-ide.python-projects.org"
+Donation = "https://www.paypal.com/donate/?hosted_button_id=XG3RSPKE3YAJ2"
+"Issues Tracker" = "https://tracker.die-offenbachs.homelinux.org/"
+"Source Code" = "https://hg.die-offenbachs.homelinux.org/eric/"
+
+[project.scripts]
+eric7_api = "eric7.eric7_api:main"
+eric7_doc = "eric7.eric7_doc:main"
+eric7_post_install = "eric7.eric7_post_install:main"
+
+[project.gui-scripts]
+eric7 = "eric7.eric7:main"
+eric7_browser = "eric7.eric7_browser:main"
+eric7_compare = "eric7.eric7_compare:main"
+eric7_configure = "eric7.eric7_configure:main"
+eric7_diff = "eric7.eric7_diff:main"
+eric7_editor = "eric7.eric7_editor:main"
+eric7_hexeditor = "eric7.eric7_hexeditor:main"
+eric7_iconeditor = "eric7.eric7_iconeditor:main"
+eric7_plugininstall = "eric7.eric7_plugininstall:main"
+eric7_pluginrepository = "eric7.eric7_pluginrepository:main"
+eric7_pluginuninstall = "eric7.eric7_pluginuninstall:main"
+eric7_qregularexpression = "eric7.eric7_qregularexpression:main"
+eric7_re = "eric7.eric7_re:main"
+eric7_shell = "eric7.eric7_shell:main"
+eric7_snap = "eric7.eric7_snap:main"
+eric7_sqlbrowser = "eric7.eric7_sqlbrowser:main"
+eric7_testing = "eric7.eric7_testing:main"
+eric7_tray = "eric7.eric7_tray:main"
+eric7_trpreviewer = "eric7.eric7_trpreviewer:main"
+eric7_uipreviewer = "eric7.eric7_uipreviewer:main"
+eric7_virtualenv = "eric7.eric7_virtualenv:main"
+
+#
+# setuptools specific parts below
+#
+
+[tool.setuptools]
+platforms = [
+    "Linux",
+    "Windows",
+    "macOS", 
+]
+include-package-data = false
+
+[tool.setuptools.dynamic]
+version = {attr = "eric7.UI.Info.VersionOnly"}
+
+[tool.setuptools.packages.find]
+where = ["src"]
+
+[tool.setuptools.package-data]
+"*" = [
+  "*.png",
+  "*.svg",
+  "*.xpm",
+  "*.ico",
+  "*.gif",
+  "*.icns",
+  "*.txt",
+  "*.md",
+  "*.rst",
+  "*.tmpl",
+  "*.html",
+  "*.qch",
+  "*.css",
+  "*.scss",
+  "*.qss",
+  "*.ehj",
+  "*.ethj",
+  "*.api",
+  "*.bas",
+  "*.dat",
+  "*.xbel",
+  "*.xml",
+  "*.js",
+  "*.json",
+  "*.desktop",
+]
+# complete translation files only
+"eric7.i18n" = [
+  "eric7_de.qm",
+  "eric7_en.qm",
+  "eric7_es.qm",
+  "eric7_ru.qm",
+]

eric ide

mercurial