setup.py

branch
eric7
changeset 9143
82f08c4fd930
parent 9135
3472875532c0
child 9175
21e2be5f0b41
--- a/setup.py	Fri Jun 10 10:41:38 2022 +0200
+++ b/setup.py	Fri Jun 10 11:12:50 2022 +0200
@@ -332,11 +332,13 @@
         "Programming Language :: Python :: 3.8",
         "Programming Language :: Python :: 3.9",
         "Programming Language :: Python :: 3.10",
+        "Programming Language :: Python :: 3.11",
+        "Programming Language :: Python :: Implementation :: CPython",
         "Topic :: Software Development",
         "Topic :: Text Editors :: Integrated Development Environments (IDE)"
     ],
     keywords="Development PyQt6 IDE Python3",
-    python_requires=">=3.7",
+    python_requires=">=3.7, <3.12",
     install_requires=[
         "pip>=21.1",
         "wheel",
@@ -393,10 +395,10 @@
             "eric7_shell = eric7.eric7_shell:main",
             "eric7_snap = eric7.eric7_snap:main",
             "eric7_sqlbrowser = eric7.eric7_sqlbrowser:main",
+            "eric7_testing = eric7.eric7_testing:main",
             "eric7_tray = eric7.eric7_tray:main",
             "eric7_trpreviewer = eric7.eric7_trpreviewer:main",
             "eric7_uipreviewer = eric7.eric7_uipreviewer:main",
-            "eric7_testing = eric7.eric7_testing:main",
             "eric7_virtualenv = eric7.eric7_virtualenv:main",
         ],
         "console_scripts": [

eric ide

mercurial