setup.py

branch
maintenance
changeset 7642
72721823d453
parent 7640
f9bb7c8c60d8
child 7657
428836188b88
--- a/setup.py	Sun May 31 17:26:46 2020 +0200
+++ b/setup.py	Sat Jul 04 11:45:34 2020 +0200
@@ -11,7 +11,7 @@
 
 import os
 import sys
-import subprocess
+import subprocess                   # secok
 import shutil
 import fnmatch
 import datetime
@@ -138,7 +138,7 @@
     except EnvironmentError:
         pass
     try:
-        hgOut = subprocess.check_output(["hg", "identify", "-i"])
+        hgOut = subprocess.check_output(["hg", "identify", "-i"])       # secok
         hgOut = hgOut.decode()
     except (OSError, subprocess.CalledProcessError):
         hgOut = ""
@@ -306,14 +306,14 @@
     keywords="Development PyQt5 IDE Python3",
     python_requires=">=3.5",
     install_requires=[
+        "pip>=19.0",
+        "wheel",
         "PyQt5>=5.12.1",
         "PyQtChart>=5.12.1",
         "PyQtWebEngine>=5.12.1",
         "QScintilla>=2.11.1",
-        "pip>=19.0",
         "docutils",
         "Markdown",
-        "wheel",
         "pywin32>=1.0;platform_system=='Windows'",
     ],
     data_files=getDataFiles(),

eric ide

mercurial