pyproject.toml

branch
eric7
changeset 9218
71cf3979a6c9
parent 9214
bd28e56047d7
child 9254
6e51b48db52e
--- a/pyproject.toml	Mon Jul 11 17:56:42 2022 +0200
+++ b/pyproject.toml	Tue Jul 12 16:26:22 2022 +0200
@@ -47,30 +47,29 @@
 ]
 requires-python = ">=3.7, <3.12"
 dependencies = [
-  "pip>=21.1",
-  "wheel",
-  "PyQt6>=6.2.0",
-  "PyQt6-Charts>=6.2.0",
-  "PyQt6-WebEngine>=6.2.0",
-  "PyQt6-QScintilla>=2.13.0",
-  "docutils",
-  "Markdown",
-  "pyyaml",
-  "tomlkit",
-  "chardet",
-  "asttokens",
-  "EditorConfig",
-  "Send2Trash",
-  "Pygments",
-  "parso",
-  "jedi",
-  "packaging",
-  "pipdeptree",
-  "cyclonedx-python-lib",
-  "cyclonedx-bom",
-  "trove-classifiers",
-  "black>=22.6.0",
-  "pywin32>=1.0;platform_system=='Windows'",
+    "pip>=21.1",
+    "wheel",
+    "PyQt6>=6.2.0",
+    "PyQt6-Charts>=6.2.0",
+    "PyQt6-WebEngine>=6.2.0",
+    "PyQt6-QScintilla>=2.13.0",
+    "docutils",
+    "Markdown",
+    "pyyaml",
+    "tomlkit",
+    "chardet",
+    "asttokens",
+    "EditorConfig",
+    "Send2Trash",
+    "Pygments",
+    "parso",
+    "jedi",
+    "packaging",
+    "cyclonedx-python-lib",
+    "cyclonedx-bom",
+    "trove-classifiers",
+    "black>=22.6.0",
+    "pywin32>=1.0;platform_system=='Windows'",
 ]
 dynamic = ["version"]
 
@@ -128,36 +127,55 @@
 
 [tool.setuptools.package-data]
 "*" = [
-  "*.png",
-  "*.svg",
-  "*.xpm",
-  "*.ico",
-  "*.gif",
-  "*.icns",
-  "*.txt",
-  "*.md",
-  "*.rst",
-  "*.tmpl",
-  "*.html",
-  "*.qch",
-  "*.css",
-  "*.scss",
-  "*.qss",
-  "*.ehj",
-  "*.ethj",
-  "*.api",
-  "*.bas",
-  "*.dat",
-  "*.xbel",
-  "*.xml",
-  "*.js",
-  "*.json",
-  "*.desktop",
+    "*.png",
+    "*.svg",
+    "*.xpm",
+    "*.ico",
+    "*.gif",
+    "*.icns",
+    "*.txt",
+    "*.md",
+    "*.rst",
+    "*.tmpl",
+    "*.html",
+    "*.qch",
+    "*.css",
+    "*.scss",
+    "*.qss",
+    "*.ehj",
+    "*.ethj",
+    "*.api",
+    "*.bas",
+    "*.dat",
+    "*.xbel",
+    "*.xml",
+    "*.js",
+    "*.json",
+    "*.desktop",
 ]
 # complete translation files only
 "eric7.i18n" = [
-  "eric7_de.qm",
-  "eric7_en.qm",
-  "eric7_es.qm",
-  "eric7_ru.qm",
+    "eric7_de.qm",
+    "eric7_en.qm",
+    "eric7_es.qm",
+    "eric7_ru.qm",
 ]
+
+[tool.black]
+target-version = ["py37", "py38", "py39", "py310", "py311"]
+line-length = 88
+extend-exclude = '''
+/(
+    Examples/
+    | ThirdParty/
+    | coverage/
+    | Ui_.*\.py
+    | pycodestyle\.py
+    | pyflakes/checker\.py
+    | mccabe\.py
+    | eradicate\.py
+    | ast_unparse\.py
+    | piplicenses\.py
+    | pipdeptree\.py
+)
+'''

eric ide

mercurial