pyproject.toml

branch
eric7
changeset 10337
64f7777ff73b
parent 10291
6b4853d7e55e
child 10341
3fdffd9cc21d
--- a/pyproject.toml	Thu Nov 23 19:57:05 2023 +0100
+++ b/pyproject.toml	Fri Nov 24 09:29:46 2023 +0100
@@ -1,5 +1,5 @@
 [build-system]
-requires = ["setuptools>=61.0.0", "wheel"]
+requires = ["setuptools>=64.0.0", "wheel"]
 build-backend = "setuptools.build_meta"
 
 [project]
@@ -32,6 +32,7 @@
     "Operating System :: Microsoft :: Windows :: Windows 10",
     "Operating System :: Microsoft :: Windows :: Windows 11",
     "Operating System :: POSIX :: BSD",
+    "Operating System :: POSIX :: BSD :: FreeBSD",
     "Operating System :: POSIX :: Linux",
     "Programming Language :: Python",
     "Programming Language :: Python :: 3",
@@ -132,9 +133,10 @@
 
 [tool.setuptools]
 platforms = [
+    "FreeBSD",
     "Linux",
+    "macOS",
     "Windows",
-    "macOS", 
 ]
 include-package-data = false
 

eric ide

mercurial