pyproject.toml

branch
eric7-maintenance
changeset 10148
31ba20629af4
parent 10123
63fa9f81fc29
child 10177
27a6e35c64ed
child 10182
dce4b2b95c3f
--- a/pyproject.toml	Sun Jul 02 17:40:17 2023 +0200
+++ b/pyproject.toml	Tue Aug 01 09:59:45 2023 +0200
@@ -35,7 +35,6 @@
     "Operating System :: POSIX :: Linux",
     "Programming Language :: Python",
     "Programming Language :: Python :: 3",
-    "Programming Language :: Python :: 3.7",
     "Programming Language :: Python :: 3.8",
     "Programming Language :: Python :: 3.9",
     "Programming Language :: Python :: 3.10",
@@ -55,7 +54,7 @@
     "IDE",
     "Python3", 
 ]
-requires-python = ">=3.7, <3.12"
+requires-python = ">=3.8, <3.12"
 dependencies = [
     "pip>=21.1",
     "wheel",
@@ -181,7 +180,7 @@
 ]
 
 [tool.black]
-target-version = ["py37", "py38", "py39", "py310", "py311"]
+target-version = ["py38", "py39", "py310", "py311", "py312"]
 line-length = 88
 extend-exclude = '''
 /(

eric ide

mercurial