setup.py

branch
eric7
changeset 8342
0613a64f1b64
parent 8318
962bce857696
child 8360
2a91e0e05926
--- a/setup.py	Fri May 21 17:43:14 2021 +0200
+++ b/setup.py	Fri May 21 17:45:47 2021 +0200
@@ -114,7 +114,7 @@
     if not longDescription:
         longDescription = (
             "eric is an integrated development environment for the Python"
-            " programming language. It uses the PyQt5 bindings and the"
+            " programming language. It uses the PyQt6 bindings and the"
             " QScintilla2 editor widget. See"
             " https://eric-ide.python-projects.org for more details."
         )
@@ -336,10 +336,10 @@
     install_requires=[
         "pip>=19.0",
         "wheel",
-        "PyQt5>=5.12.1,<5.15.2",
-        "PyQtChart>=5.12.1,<5.15.2",
-        "PyQtWebEngine>=5.12.1,<5.15.2",
-        "QScintilla>=2.11.1",
+        "PyQt6>=6.1.1",
+        "PyQt6-Charts>=6.1.0",
+        #~ "PyQt6-WebEngine>=6.2.0",
+        "PyQt6-QScintilla>=2.12.2",
         "docutils",
         "Markdown",
         "pyyaml",
@@ -369,7 +369,7 @@
     entry_points={
         "gui_scripts": [
             "eric7 = eric7.eric7:main",
-            "eric7_browser = eric7.eric7_browser:main",
+            #~ "eric7_browser = eric7.eric7_browser:main",
             "eric7_compare = eric7.eric7_compare:main",
             "eric7_configure = eric7.eric7_configure:main",
             "eric7_diff = eric7.eric7_diff:main",

eric ide

mercurial