setup.py: changed the order of packages in 'install_requires'. Hopefully this install pip and wheel before PyQt5.

Fri, 03 Jul 2020 17:37:11 +0200

author
Detlev Offenbach <detlev@die-offenbachs.de>
date
Fri, 03 Jul 2020 17:37:11 +0200
changeset 7640
f9bb7c8c60d8
parent 7639
422fd05e9c91
child 7641
21ea4fd50b0a

setup.py: changed the order of packages in 'install_requires'. Hopefully this install pip and wheel before PyQt5.

setup.py file | annotate | diff | comparison | revisions
--- a/setup.py	Sat Jun 27 12:08:12 2020 +0200
+++ b/setup.py	Fri Jul 03 17:37:11 2020 +0200
@@ -306,14 +306,14 @@
     keywords="Development PyQt5 IDE Python3",
     python_requires=">=3.5",
     install_requires=[
+        "pip>=19.0",
+        "wheel",
         "PyQt5>=5.12.1",
         "PyQtChart>=5.12.1",
         "PyQtWebEngine>=5.12.1",
         "QScintilla>=2.11.1",
-        "pip>=19.0",
         "docutils",
         "Markdown",
-        "wheel",
         "pywin32>=1.0;platform_system=='Windows'",
     ],
     data_files=getDataFiles(),

eric ide

mercurial