install-debugclients.py: reverted the Python2 related changes because the debug client still supports Python2.

Mon, 09 Sep 2019 19:07:48 +0200

author
Detlev Offenbach <detlev@die-offenbachs.de>
date
Mon, 09 Sep 2019 19:07:48 +0200
changeset 7228
6037ddba57aa
parent 7227
5ba312e6599a
child 7229
53054eb5b15a

install-debugclients.py: reverted the Python2 related changes because the debug client still supports Python2.

scripts/install-debugclients.py file | annotate | diff | comparison | revisions
--- a/scripts/install-debugclients.py	Mon Sep 09 18:52:08 2019 +0200
+++ b/scripts/install-debugclients.py	Mon Sep 09 19:07:48 2019 +0200
@@ -12,6 +12,17 @@
 """
 
 from __future__ import unicode_literals, print_function
+try:
+    import cStringIO as io
+    try:
+        from PyQt5 import sip
+    except ImportError:
+        import sip
+    sip.setapi('QString', 2)
+    sip.setapi('QVariant', 2)
+    sip.setapi('QTextStream', 2)
+except (ImportError):
+    import io    # __IGNORE_WARNING__
 
 import sys
 import os
@@ -19,7 +30,6 @@
 import compileall
 import shutil
 import fnmatch
-import io
 
 # Define the globals.
 progName = None
@@ -242,8 +252,11 @@
     global progName, modDir, doCleanup, doCompile, distDir
     global sourceDir
     
-    if sys.version_info < (3, 5, 0) or sys.version_info > (3, 99, 99):
-        print('Sorry, eric6 requires at least Python 3.5 for running.')
+    if sys.version_info < (2, 7, 0) or \
+       (sys.version_info >= (3, 0, 0) and sys.version_info < (3, 5, 0)) \
+       or sys.version_info > (3, 99, 99):
+        print('Sorry, the eric6 debugger requires Python 2.7 or'
+              'Python 3.5 or better for running.')
         exit(5)
     
     progName = os.path.basename(argv[0])

eric ide

mercurial