install script: changed minimum version for Qt/PyQt to 5.12.0.

Sat, 03 Oct 2020 15:23:58 +0200

author
Detlev Offenbach <detlev@die-offenbachs.de>
date
Sat, 03 Oct 2020 15:23:58 +0200
changeset 7740
330a43a4db79
parent 7739
31a175406775
child 7741
6ead5f865f72

install script: changed minimum version for Qt/PyQt to 5.12.0.

scripts/install.py file | annotate | diff | comparison | revisions
--- a/scripts/install.py	Sat Oct 03 15:22:59 2020 +0200
+++ b/scripts/install.py	Sat Oct 03 15:23:58 2020 +0200
@@ -1525,8 +1525,8 @@
     qtMajor = int(qVersion().split('.')[0])
     qtMinor = int(qVersion().split('.')[1])
     print("Qt Version: {0}".format(qVersion().strip()))
-    if qtMajor == 5 and qtMinor < 9:
-        print('Sorry, you must have Qt version 5.9.0 or better.')
+    if qtMajor == 5 and qtMinor < 12:
+        print('Sorry, you must have Qt version 5.12.0 or better.')
         exit(2)
     
     # check version of sip
@@ -1576,8 +1576,8 @@
         major = int(major)
         minor = int(minor)
         pat = int(pat)
-        if major == 5 and minor < 9:
-            print('Sorry, you must have PyQt 5.9.0 or better or'
+        if major == 5 and minor < 12:
+            print('Sorry, you must have PyQt 5.12.0 or better or'
                   ' a recent snapshot release.')
             exit(4)
         # check for blacklisted versions

eric ide

mercurial