install.py: don't ask to install 'pyqt5-tools' on macOS because it is not available for this platform.

Sun, 18 Oct 2020 11:39:24 +0200

author
Detlev Offenbach <detlev@die-offenbachs.de>
date
Sun, 18 Oct 2020 11:39:24 +0200
changeset 7799
5aeb0122e063
parent 7798
0779dd5a84ca
child 7800
96fae5353698

install.py: don't ask to install 'pyqt5-tools' on macOS because it is not available for this platform.

scripts/install.py file | annotate | diff | comparison | revisions
diff -r 0779dd5a84ca -r 5aeb0122e063 scripts/install.py
--- a/scripts/install.py	Sun Oct 18 11:30:12 2020 +0200
+++ b/scripts/install.py	Sun Oct 18 11:39:24 2020 +0200
@@ -1472,9 +1472,10 @@
         # available (e.g. for 32-Bit Windows)
         (("PyQt5.QtWebEngineWidgets", ), sys.maxsize <= 2**32),
     ]
-    optionalModulesList = {
-        "pyqt5-tools": "pyqt5_tools",
-    }
+    optionalModulesList = {}
+    if sys.platform != "darwin":
+        optionalModulesList["pyqt5-tools"] = "pyqt5_tools"
+    
     # check mandatory modules
     modulesOK = True
     for impModule in impModulesList:

eric ide

mercurial