Change to the plug-in manager to support plug-in sets (like the documentation sets plug-ins). These containe a '_' in the plug-in archive name. 6_1_x

Sun, 16 Oct 2016 11:44:20 +0200

author
Detlev Offenbach <detlev@die-offenbachs.de>
date
Sun, 16 Oct 2016 11:44:20 +0200
branch
6_1_x
changeset 5237
56761e8a4d95
parent 5235
3ea533fbcb4c
child 5249
a114f080572f

Change to the plug-in manager to support plug-in sets (like the documentation sets plug-ins). These containe a '_' in the plug-in archive name.
(grafted from 9487d3fbb71eb055fcc8d78205ec1e947c399352)

PluginManager/PluginManager.py file | annotate | diff | comparison | revisions
diff -r 3ea533fbcb4c -r 56761e8a4d95 PluginManager/PluginManager.py
--- a/PluginManager/PluginManager.py	Sat Oct 15 16:22:04 2016 +0200
+++ b/PluginManager/PluginManager.py	Sun Oct 16 11:44:20 2016 +0200
@@ -801,6 +801,9 @@
             module = self.__failedModules[name]
             autoactivate = False
             active = False
+        elif "_" in name:
+            # try stripping of a postfix
+            return self.getPluginDetails(name.rsplit("_", 1)[0])
         else:
             # should not happen
             return None

eric ide

mercurial