scripts/install-debugclients.py

changeset 7637
c878e8255972
parent 7628
f904d0eef264
child 7639
422fd05e9c91
--- a/scripts/install-debugclients.py	Mon Jun 22 17:55:06 2020 +0200
+++ b/scripts/install-debugclients.py	Tue Jun 23 17:24:18 2020 +0200
@@ -252,13 +252,9 @@
     global progName, modDir, doCleanup, doCompile, distDir
     global sourceDir
     
-    if (
-        sys.version_info < (2, 7, 0) or
-        (sys.version_info >= (3, 0, 0) and sys.version_info < (3, 5, 0)) or
-        sys.version_info >= (4, 0, 0)
-    ):
-        print('Sorry, the eric6 debugger requires Python 2.7 or'
-              'Python 3.5 or better for running.')
+    if sys.version_info < (3, 5, 0) or sys.version_info >= (4, 0, 0):
+        print('Sorry, the eric6 debugger requires Python 3.5 or better'
+              ' for running.')
         exit(5)
     
     progName = os.path.basename(argv[0])

eric ide

mercurial