install.py

changeset 3542
07cde1e38b06
parent 3539
0c2dc1446ebf
child 3593
e3435c1ce0cf
--- a/install.py	Sun Apr 27 10:58:35 2014 +0200
+++ b/install.py	Sun Apr 27 19:18:34 2014 +0200
@@ -872,7 +872,7 @@
         print('Sorry, you must have Python 3.1.0 or higher.')
         exit(5)
     if sys.version_info > (3, 9, 9):
-        print('Sorry, eric5 requires Python 3 for running.')
+        print('Sorry, eric5 requires Python 3 or Python 2 for running.')
         exit(5)
     print("Python Version: {0:d}.{1:d}.{2:d}".format(*sys.version_info[:3]))
     
@@ -1122,7 +1122,7 @@
         if sys.platform.startswith("win"):
             optlist, args = getopt.getopt(argv[1:], "chxza:b:d:f:")
         elif sys.platform == "darwin":
-            optlist, args = getopt.getopt(argv[1:], "chxza:b:d:f:i:m:p:")
+            optlist, args = getopt.getopt(argv[1:], "chxza:b:d:f:i:m:n:p:")
         else:
             optlist, args = getopt.getopt(argv[1:], "chxza:b:d:f:i:")
     except getopt.GetoptError:

eric ide

mercurial