eric6_browser.py

branch
QtWebEngine
changeset 4726
c26e2a2dc0cb
parent 4725
b19ff70ba509
child 4727
62b50a24fb59
equal deleted inserted replaced
4725:b19ff70ba509 4726:c26e2a2dc0cb
29 29
30 import sys 30 import sys
31 import os 31 import os
32 32
33 # TODO: adjust this when done 33 # TODO: adjust this when done
34 MIN_QT_VERSION = "5.5.0" 34 MIN_QT_VERSION = "5.6.0"
35 35
36 from PyQt5.QtCore import qVersion 36 from PyQt5.QtCore import qVersion
37 if qVersion() < MIN_QT_VERSION: 37 if qVersion() < MIN_QT_VERSION:
38 print("You need at least Qt Version {0} to execute the web browser." 38 try: # Py2
39 import tkMessageBox as messagebox
40 except ImportError:
41 try: # Py3
42 from tkinter import messagebox
43 except ImportError:
44 sys.exit(100)
45 messagebox.showerror(
46 "eric6 Error",
47 "You need at least Qt Version {0} to execute the web browser."
39 .format(MIN_QT_VERSION)) 48 .format(MIN_QT_VERSION))
40 sys.exit(100) 49 sys.exit(100)
41 50
42 for arg in sys.argv[:]: 51 for arg in sys.argv[:]:
43 if arg.startswith("--config="): 52 if arg.startswith("--config="):

eric ide

mercurial