eric6_webbrowser.py

branch
6_1_x
changeset 4938
78287a4f976b
parent 4632
ca310db386ed
child 5389
9b1c800daff3
equal deleted inserted replaced
4936:f68a61f6b5ca 4938:78287a4f976b
27 except AttributeError: 27 except AttributeError:
28 pass 28 pass
29 29
30 import sys 30 import sys
31 import os 31 import os
32
33 try:
34 from PyQt5 import QtWebKit # __IGNORE_WARNING__
35 except ImportError:
36 from PyQt5.QtCore import qVersion, QTimer
37 from PyQt5.QtWidgets import QApplication
38 from E5Gui import E5MessageBox
39 app = QApplication([])
40 QTimer.singleShot(0, lambda: E5MessageBox.critical(
41 None,
42 "eric6 Web Browser (QtWebKit based)",
43 "QtWebKit is needed to run this variant of the eric6 Web Browser."
44 " However, it seems to be missing. You are using Qt {0}, which"
45 " doesn't include this anymore.".format(qVersion())))
46 app.exec_()
47 sys.exit(100)
32 48
33 for arg in sys.argv[:]: 49 for arg in sys.argv[:]:
34 if arg.startswith("--config="): 50 if arg.startswith("--config="):
35 import Globals 51 import Globals
36 configDir = arg.replace("--config=", "") 52 configDir = arg.replace("--config=", "")

eric ide

mercurial