scripts/install.py

branch
eric7
changeset 8753
6888dacf86b6
parent 8739
55e07d9608f0
child 8754
e7d63a5a2ae9
equal deleted inserted replaced
8752:3c1ea4dfb691 8753:6888dacf86b6
1473 if not isSudo and isPipOutdated(): 1473 if not isSudo and isPipOutdated():
1474 updatePip() 1474 updatePip()
1475 print("\n") 1475 print("\n")
1476 1476
1477 # perform dependency checks 1477 # perform dependency checks
1478 print("Python Version: {0:d}.{1:d}.{2:d}".format(*sys.version_info[:3]))
1479 if sys.version_info < (3, 6, 0): 1478 if sys.version_info < (3, 6, 0):
1480 print('Sorry, you must have Python 3.6.0 or higher.') 1479 print('Sorry, you must have Python 3.6.0 or higher.')
1481 exit(5) 1480 exit(5)
1482 1481
1483 try: 1482 try:
1643 else: 1642 else:
1644 PlatformBlackLists = PlatformsBlackLists["mac"] 1643 PlatformBlackLists = PlatformsBlackLists["mac"]
1645 1644
1646 print("\nVersion Information") 1645 print("\nVersion Information")
1647 print("-------------------") 1646 print("-------------------")
1647
1648 print("Python Version: {0:d}.{1:d}.{2:d}".format(*sys.version_info[:3]))
1648 1649
1649 # check version of Qt 1650 # check version of Qt
1650 # =================== 1651 # ===================
1651 qtMajor = int(qVersion().split('.')[0]) 1652 qtMajor = int(qVersion().split('.')[0])
1652 qtMinor = int(qVersion().split('.')[1]) 1653 qtMinor = int(qVersion().split('.')[1])

eric ide

mercurial