Utilities/__init__.py

changeset 3656
441956d8fce5
parent 3628
deb5973080a9
child 3670
f0cb7579c0b4
equal deleted inserted replaced
3654:ffeb85cdc72d 3656:441956d8fce5
54 import warnings 54 import warnings
55 warnings.showwarning = __showwarning 55 warnings.showwarning = __showwarning
56 56
57 from codecs import BOM_UTF8, BOM_UTF16, BOM_UTF32 57 from codecs import BOM_UTF8, BOM_UTF16, BOM_UTF32
58 58
59 from PyQt4.QtCore import QRegExp, QDir, QProcess, Qt, QByteArray, \ 59 from PyQt5.QtCore import QRegExp, QDir, QProcess, Qt, QByteArray, \
60 qVersion, PYQT_VERSION_STR, QCoreApplication, QCryptographicHash 60 qVersion, PYQT_VERSION_STR, QCoreApplication, QCryptographicHash
61 from PyQt4.Qsci import QSCINTILLA_VERSION_STR, QsciScintilla 61 from PyQt5.Qsci import QSCINTILLA_VERSION_STR, QsciScintilla
62 62
63 # import these methods into the Utilities namespace 63 # import these methods into the Utilities namespace
64 from Globals import ( # __IGNORE_WARNING__ 64 from Globals import ( # __IGNORE_WARNING__
65 isWindowsPlatform, isLinuxPlatform, isMacPlatform, getConfigDir, 65 isWindowsPlatform, isLinuxPlatform, isMacPlatform, getConfigDir,
66 setConfigDir, getPythonModulesDirectory, getPyQt4ModulesDirectory, 66 setConfigDir, getPythonModulesDirectory, getPyQt5ModulesDirectory,
67 getQtBinariesPath) 67 getQtBinariesPath)
68 68
69 from E5Gui.E5Application import e5App 69 from E5Gui.E5Application import e5App
70 70
71 from UI.Info import Program, Version 71 from UI.Info import Program, Version
1594 except (ImportError, AttributeError): 1594 except (ImportError, AttributeError):
1595 sip_version_str = "sip version not available" 1595 sip_version_str = "sip version not available"
1596 1596
1597 info = "Version Numbers:{0} Python {1}{2}".format( 1597 info = "Version Numbers:{0} Python {1}{2}".format(
1598 linesep, sys.version.split()[0], linesep) 1598 linesep, sys.version.split()[0], linesep)
1599 info += " Qt {0}{1} PyQt4 {2}{3}".format( 1599 info += " Qt {0}{1} PyQt5 {2}{3}".format(
1600 qVersion(), linesep, PYQT_VERSION_STR, linesep) 1600 qVersion(), linesep, PYQT_VERSION_STR, linesep)
1601 info += " sip {0}{1} QScintilla {2}{3}".format( 1601 info += " sip {0}{1} QScintilla {2}{3}".format(
1602 sip_version_str, linesep, QSCINTILLA_VERSION_STR, linesep) 1602 sip_version_str, linesep, QSCINTILLA_VERSION_STR, linesep)
1603 try: 1603 try:
1604 from PyQt4.QtWebKit import qWebKitVersion 1604 from PyQt5.QtWebKit import qWebKitVersion
1605 info += " WebKit {0}{1}".format(qWebKitVersion(), linesep) 1605 info += " WebKit {0}{1}".format(qWebKitVersion(), linesep)
1606 except ImportError: 1606 except ImportError:
1607 pass 1607 pass
1608 info += " {0} {1}{2}".format( 1608 info += " {0} {1}{2}".format(
1609 Program, Version, linesep * 2) 1609 Program, Version, linesep * 2)

eric ide

mercurial